POTC Fansite Home POTCF Forums POTCF Gallery Blogs POTCF Arr!cade POTCF User Pages Register! Casino!

Go Back   Pirates of the Caribbean Online Fansite & Forums > Group Forums > The Helm > The Aft
Blogs FAQDonate Calendar Arcade Mark Forums Read

Notices

The Aft Secret Beta POTCO Discussion Archive Forum

Old Equiping trouble

Login or Register now to see less ads.

 
 
Thread Tools Display Modes
  #1  
Old 05-06-2007, 08:49 PM
dragonfly0521 dragonfly0521 is offline
Founder
dragonfly0521's Primary Pirate Info

Join Date: Apr 2007
Posts: 3
dragonfly0521 is scurvy dog
Equiping trouble

Hi there... getting used to some of the gameplay, but having problems equiping an upgraded cutlass and sometimes I cannot equip a healing elixer. I am a cutlass level 7. I was able to buy the new cutlass (just the 200 gold version) but when I try to equip it it says that I need cutlass training. I thought I already had that. But it also says that on the Rusty Cutlass that I have equipped. Anyone else have this? Thanks!
  #2  
Old 05-06-2007, 09:02 PM
Amasette's Avatar
Amasette Amasette is offline
Eliza Truescarlett
Amasette's Primary Pirate Info

Join Date: Apr 2007
Posts: 39
Amasette is scurvy dog
Umm...a few days ago I accidentally equipped all of my slots with my pistol...since then, I haven't been able to reequip my rusty cutlass. I was about a level 5 on it, I think...now I get the same thing--it's shaded red and says I need training. I've reported it...hopefully they'll fix the problem!
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:20 PM.

POF on Facebook

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.